Back to overview
Resolved

Trouble Signing Up

May 21, 2025 at 10:57am UTC
Affected services
Feelo Web

Resolved
May 10, 2026 at 6:34am UTC

Incident Post Mortem

Between the hour of 12:30 and 13:15, CEST, on the 21st of May 2025, a large amount of users encountered issues when signing up to the service.

The event was triggered by a change in the login flow of our website at approx. 12:25. This modified the UI of our Login System, along with Firebase User document creation, which all user data is based on. This bug caused users to be met with generic placeholder data when creating an account, or signing in.

The event was marked with an increased amount of support queries, duing a live testing session. Our team immediately began identifying the root cause of the issue and implementing fixes.

At 12:25, on 21-05-2025 (5 minutes before the incident in question, and before a live testing session with selected beta testers), a change was introduced to the login flow of our service in order to improve the user experience and move on from a traditional temporary login page.

This change resulted in Firebase failing to create User Documents, and failing to load user documents from the server. This was caused due to a change in the logic flow of Authentication, which caused users to me met with generic, testing/demo data.

After receiving multiple reports, our on-site demo engineers began working on identifying the issue, along with out custom relations representatives, that made the decision to delay the demo session by 1 hour.

We sincerely apologize to the users affected, and we are taking internal measures along with tests to limit the chance of an incident like this happening again.

Updated
May 21, 2025 at 11:14am UTC

We’re back! Signing Up should be up and running. Thanks for bearing with us.

Updated
May 21, 2025 at 11:11am UTC

We have identified the root cause of the issue. We can now confirm that Sign-Up using Google is working. We are testing email sign up as we speak. Expect an update within 5 minutes.

Created
May 21, 2025 at 10:57am UTC

Some users may be experiencing trouble when signing up to Feelo. Our team is currently investigating issues related to FlutterFlow Firebase document creation.

All users that have signed up since the launch are affected.

We will send an additional update in 30 minutes.